附录更换系统盘应该注意什么问题?更换系统盘之前建议您创建快照备份数据,并且您需要确保系统盘有1GiB以上的预留空间。否则更换系统盘后,实例可能无法正常启动。
系统盘价格请参见块存储价格。
怎么避免错误操作引起的数据丢失?在有操作风险的场景中,您可以提前创建快照备份数据。例如修改关键系统文件、日常数据备份、实例误释放恢复、预防网络攻击、更换操作系统、为生产环境提供数据支撑和其他具有操作风险的场景。出现错误操作时,您可以及时回滚云盘,降低风险。更多信息,请参见手动创建单个快照和使用快照回滚云盘。
本地盘支持创建快照吗?不支持。建议您在应用层做好数据冗余处理,或者为集群创建部署集,提高应用的高可用性。更多信息,请参见本地盘。
在ECS实例内删除文件会减少空间占用吗?不会。删除文件操作相当于在需要删除的文件头部做删除标记,并不会减少云盘本身的空间占用。
为什么快照容量大于文件系统内看到的数据量?问题现象:您在ECS实例内删除文件后再创建快照,发现快照容量并没有变小,或者快照比从文件系统查询到的云盘占用空间大。
原因分析:格式化文件系统操作、删除文件操作以及写入数据操作都会使云盘空块数量不断减少,减弱了创建快照时消除空块的能力。因此,您看到快照容量比文件系统内展示的数据量要大。以下原因可能造成文件系统与快照大小不一致:
文件系统的元数据会占用磁盘空间。
文件系统在初始化阶段被写入大量数据块(Block,指磁盘的逻辑块地址LBA被块存储划分为相同大小的块),写入数据操作会占用磁盘空间。
文件系统为了降低性能消耗,删除文件时只在文件属性中创建弃用标记。磁盘无法感知删除指令,数据块仍然是已分配状态,同时数据块会被拷贝到快照中,导致快照容量大于文件系统。
虚拟化驱动KVM的Virtio-block和Xen的Block-front等模块不支持TRIM指令(磁盘I/O指令,提示逻辑块地址LBA上的某段数据不再使用,可以被删除),磁盘无法感知数据可以被删除。
如何查看不同地域下快照价格?您可以访问ECS定价详情页,在快照服务价格页签下查看各地域的快照单价。
为什么购买了OSS资源包,快照还在计费?OSS资源包与产生的计费项不匹配
对象存储OSS资源包包含存储包、流量包等多种资源包类型,只有标准-本地冗余存储包才可以抵扣快照的存储费用,请您检查购买的资源包类型。更多信息,请参见资源包。
OSS资源包仅可以抵扣标准快照的存储容量费用,不能抵扣快照复制流量费。
OSS资源包所在地域与产生费用的地域不匹配
您购买的是某个地域的OSS资源包,而快照实际产生的费用发生在其他地域。例如华东2(上海)产生的快照存储费用无法使用华东1(杭州)的OSS资源包进行抵扣。
快照实际使用量超出了OSS资源包规格
OSS资源包抵扣快照存储容量部分的费用时,超出部分自动采用按量付费。
更多信息,请参见OSS资源包。
我已经购买了OSS资源包,同时使用快照和OSS服务时,资源包会优先抵扣哪个产品?当前资源包抵扣顺序是按照产品出账时间,因此没有优先抵扣的规则。
OSS资源包和存储容量单位包SCU有什么区别?OSS资源包:对象存储OSS资源包是一种预付费的资源包,包含存储包、流量包等多种资源包类型。如果您购买OSS资源包时选择了标准-本地冗余存储包,可以抵扣快照的存储费用,超出部分自动采用按量付费。更多信息,请参见OSS资源包。
存储容量单位包SCU:一种包年包月的预付费资源包,可以抵扣云盘、快照和对象存储OSS等多种存储产品的存储容量费用。购买SCU后,可以自动抵扣同地域内云盘和快照的按量付费账单。如果云盘和快照实际容量超出了SCU容量,超出部分自动采用按量付费。更多信息,请参见存储容量单位包SCU。
如果您同时购买了OSS资源包和存储容量单位包SCU,则优先使用OSS资源包抵扣快照存储费用,然后再使用SCU抵扣快照存储费用,超出部分自动采用按量付费。您可以按需结合使用OSS资源包和存储容量单位包SCU抵扣快照存储费用账单,以节约快照使用成本。资源包的抵扣示例请参见OSS资源包抵扣示例、存储容量单位包抵扣示例。
快照采用什么计费方式?使用快照可能产生的费用包括
快照存储费
和
快照复制流量费
两部分,默认采用按量付费的计费方式。购买
标准-本地冗余存储包和
存储容量单位包SCU可以抵扣快照存储费,但不支持抵扣快照复制流量费。更多信息,请参见
快照计费
。
快照消费是否可以开发票?可以,您可以在费用中心申请开具发票。发票需基于订单或月度结算,单个订单或月结算单不可拆分为多张发票;但多个订单或月结算单可以合并,开具一张发票。更多信息,请参见发票申请指南。
快照有免费使用额度吗?暂时没有。快照为计费服务,一旦创建快照就会产生计费账单。有关快照计费的更多信息,请参见快照计费。
开通快照是否收费?开通快照服务免费。创建快照后,系统根据您使用的快照容量大小开始计费。
快照计费的更多信息,请参见快照计费。
开通快照的更多信息,请参见开通快照。
使用自动快照策略是否收费?自动快照策略本身不收费,但是通过自动快照策略创建的自动快照会收费。只要创建了快照就会产生费用,不论是自动快照还是手动创建快照。更多信息,请参见快照计费。
使用快照一致性组功能是否收费?快照一致性组本身不收费,但是会收取一致性组内各个云盘快照的容量费用。更多信息,请参见快照计费。
删除云盘的时候,快照会被保留吗?手动快照不会被删除。
自动快照是否会被删除,取决于您是否开启自动快照随云盘释放属性。更多信息,请参见设置自动快照随云盘释放。
为什么我的云盘没有自动快照了?快照数量达到快照配额后,系统会自动删除最早创建的自动快照,手动快照不受影响。
说明 云盘只有挂载到实例时才会执行自动快照策略。
重新初始化云盘时,我的快照会丢失吗?不会,手动快照和自动快照都不会丢失。
更换系统盘时,我的快照会丢失吗?历史系统盘的手动快照仍旧保留,如果自动快照设置了自动快照随磁盘释放则会被删除。
说明 更换系统盘后云盘ID会发生变化,历史系统盘的快照将不能用于回滚新的系统盘。
快照能否下载或导出到本地? 快照不能下载或导出到本地。您可以先使用快照创建自定义镜像,然后再导出自定义镜像到本地。
说明 导出自定义镜像有一些限制约束,请您首先确认利用快照创建的镜像是否满足导出要求。
如何查看快照存储的数据?无法直接在快照中查看数据,您可以通过以下方式查看快照存储的数据。
使用快照创建云盘,然后将新云盘挂载至ECS实例查看快照存储的数据。
使用快照创建自定义镜像,然后使用自定义镜像创建新的ECS实例查看快照存储的数据。
使用快照创建了自定义镜像,可以将镜像存到OSS Bucket吗?自定义镜像无法直接存储到OSS Bucket。您可以将快照创建自定义镜像通过导出镜像的方式,导出到您设置的OSS Bucket,然后从OSS Bucket中下载使用。具体操作,请参见导出自定义镜像。
如何避免快照被阿里云删除?快照是否删除受快照的保留时间影响。
在手动创建快照和创建自动快照策略时可以选择永久保留或自定义保留天数。快照超过保留时间后,将被系统自动删除。您可以根据需要延长手动快照和自动快照的保留时间。具体操作,请参见延长快照保留时间。
自动快照如果开启自动快照随云盘属性,当释放云盘(手动释放云盘、云盘随实例释放或更换系统盘)时,即使快照未到期,自动快照也会随云盘释放而提前删除。您可以关闭自动快照随云盘属性,释放云盘时不会删除快照。具体操作,请参见设置自动快照随云盘释放。
更换系统盘、释放实例或释放云盘后,快照会被删除吗?场景
更换系统盘
释放实例
释放云盘
手动快照
不受影响。
自动快照
如果旧系统盘开启自动快照随云盘属性,自动快照随云盘释放。
如果旧系统盘关闭自动快照随云盘属性,自动快照遵循快照策略的保留时间。
旧系统盘的自动快照策略失效,需要重新设置。
如果同时开启云盘随实例释放和自动快照随云盘属性,云盘将随实例释放,自动快照随云盘释放。
如果开启自动快照随云盘属性,自动快照随云盘释放。
如果关闭自动快照随云盘属性,自动快照遵循快照策略的保留时间。
如何删除已创建了镜像、云盘的快照?创建过云盘的快照,可以强制删除。删除快照后,您将无法操作依赖于原始快照数据状态的业务,例如重新初始化云盘。
创建过自定义镜像的快照,必须先删除镜像,才能删除快照。
更多信息,请参见删除快照。
删除快照链列表内的一份快照,为什么提示我关联了“RequestId: xxx”? 您的快照创建了自定义镜像,需要先删除这个自定义镜像才可以删除快照。具体操作,请参见删除自定义镜像。
如果我用自动快照创建自定义镜像或云盘,执行快照策略会失败吗?不会。您可以将已创建的自动快照策略关联到云盘,关联后,阿里云会自动按照自动快照策略设置的时间点或周期为云盘自动创建快照,不会影响自动快照策略的执行。
一块云盘能否设置多个自动快照策略?默认单云盘仅可绑定一个策略,如需多策略绑定,请参考为云盘设置自动快照策略。
创建自动快照策略时选择保留时间为永久保留,快照还能删除吗?可以删除。
确认快照不再使用后,您可以直接手动删除快照。具体操作,请参见删除快照。
您也可以开启自动快照随云盘属性,释放云盘时会同步删除该云盘的自动快照。
重启Linux系统ECS实例或者重新初始化系统盘后数据盘不见了怎么办?问题现象:Linux实例重启或初始化系统之后,再登录实例运行df -h查看云盘挂载,发现数据盘不见了。
问题原因:
重启实例:如果重启实例前,您没有将挂载信息写入到/etc/fstab中,重启实例之后实例不会自动挂载数据盘。
重新初始化系统盘:初始化系统盘会重置/etc/fstab文件,重新初始化系统盘后实例不会自动挂载数据盘。
解决方案:
本方法以非I/O优化实例/dev/xvdb1分区为例。如果是I/O优化实例非NVMe协议挂载的数据盘,云盘设备名为/dev/vd[b-z];如果是I/O优化实例NVMe协议挂载的数据盘,云盘设备名为/dev/nvmeXn1。请您根据实际情况操作。
运行mount /dev/xvdb1命令重新挂载数据盘。
运行mount命令查看数据盘分区/dev/xvdb1的文件格式。
假设您查看到/dev/xvdb1分区使用的是ext3文件系统,执行以下命令将数据盘挂载信息写入到/etc/fstab文件中。
echo '/dev/xvdb1 /data ext3 defaults 0 0' >> /etc/fstab在控制台重启ECS实例。
数据盘进行二次分区后,此时回滚快照后,数据盘是几个分区?快照回滚是回滚到快照时间点,如果该时间点尚未进行二次分区,则没有多个分区。
回滚云盘时为什么报错“执行回滚磁盘需要停止实例,并且确保当前磁盘没有创建中的快照和没有更换过操作系统。”?问题现象:回滚云盘时,报错“执行回滚云盘需要停止实例,并且确保当前云盘没有创建中的快照和没有更换过操作系统。”
问题原因:通常是由于云盘属性或云盘状态不符等原因导致。
解决方案:您可以根据实例状态和相关快照任务排查故障。
检查实例是否已经正常停止。
只有已停止的实例才能进行云盘回滚操作。您可以在控制台的实例列表页查看实例状态。
检查相关快照所关联的实例是否更换过系统盘。
如果更换了操作系统,实例的系统盘会随新镜像自动重新创建,系统盘ID会改变。所以,实例原有的快照将无法再用于回滚。但您可以基于相关快照创建自定义镜像,然后再通过更换系统盘方式指定该自定义镜像,将实例切换到相应的快照状态。具体操作,请参见使用快照创建自定义镜像和更换操作系统(更换系统盘)。
检查相关快照归属的云盘是否有正在创建快照。
为保障数据一致性,如果快照归属云盘有正在进行的快照任务,将不允许进行回滚操作。您可以在实例详情页的快照页签中,查看是否存在进度不是100%,状态处于未完成的快照任务。
如果您需要强制终止相关快照任务以便尽快进行云盘回滚操作,可以勾选相应快照,并单击删除快照终止快照任务。
ECS实例释放后,如何通过快照快速恢复数据?ECS实例释放后,您可以通过以下方法快速恢复数据:
使用快照创建自定义镜像。
使用自定义镜像或共享镜像创建实例。
远程连接新建的ECS实例,查看数据是否恢复完整,并进行拷贝或进一步处理。
重要 新建实例可能产生计算和存储费用,建议您在数据恢复完成后尽快释放实例,避免产生额外费用。
更换系统盘后,历史系统盘快照能否用于回滚新的系统盘?不能。
说明
您可以使用历史快照创建新的按量付费云盘,然后挂载到ECS实例上做数据恢复。数据恢复后,建议及时释放云盘。具体操作,请参见使用快照创建数据盘、挂载数据盘和释放云盘。
之前实例的地域为中国杭州,数据盘有快照。实例到期释放后我在中国杭州地域又新购了一台实例,能否回滚到之前的实例? 不能,使用快照回滚云盘需要回滚到原来的实例。但您可以利用之前数据盘的快照创建云盘,将云盘挂载到新的实例上。具体操作,请参见使用快照创建数据盘和挂载数据盘。
服务器下的快照无法回滚,是什么原因?您可以根据回滚云盘的报错信息,检查快照情况。常见问题及解决方案,请参见块存储FAQ中的回滚云盘相关问题。
数据盘快照可以创建自定义镜像吗?不可以。创建自定义镜像的快照云盘属性必须是系统盘。
ECS实例释放后,如何通过快照快速恢复数据?ECS实例释放后,您可以通过以下方法快速恢复数据:
使用快照创建自定义镜像。
使用自定义镜像或共享镜像创建实例。
远程连接新建的ECS实例,查看数据是否恢复完整,并进行拷贝或进一步处理。
重要 新建实例可能产生计算和存储费用,建议您在数据恢复完成后尽快释放实例,避免产生额外费用。
Linux系统ECS实例重新初始化系统盘后如何重新挂载数据盘?在Linux实例中,重新初始化系统盘不会改变数据盘里的内容,但是数据盘的挂载信息会丢失。假设重新初始化系统盘之前,实例上挂载的数据盘分区名称为/dev/vdb1,挂载点名称为/InitTest。重启Linux实例后,请参见以下步骤创建新的挂载点信息并挂载数据盘分区。
运行mount查看数据盘挂载信息。
返回结果中没有/dev/vdb1的信息。
运行fdisk -l查看数据盘分区信息。
运行cat /etc/fstab查看数据盘分区/dev/vdb1原有的挂载点名称。
运行mkdir /InitTest重新创建数据盘分区的挂载点。
新建的挂载点名称必须与重新初始化系统盘之前/dev/vdb1的挂载点名称保持一致。
运行mount /dev/vdb1 /InitTest重新挂载数据盘分区。
运行df -h查看挂载结果。
按以下步骤检测数据盘/dev/vdb1是否能自动挂载。
运行umount /dev/vdb1卸载/dev/vdb1。
运行mount查看挂载信息。
如果卸载成功,返回结果中不会有/dev/vdb1的信息。
运行mount -a自动挂载/dev/vdb1。
运行mount查看挂载信息。
如果自动挂载成功,返回结果中会有/dev/vdb1的信息。
手动快照和自动快照有什么区别?手动快照和自动快照在本质上没有区别,都是某一时间点一块云盘数据的完整拷贝。但是存在以下区别:
创建方式不同
手动快照需要每次手动创建。您可以在快照或云盘页面,根据需要自定义快照参数,手动为云盘创建快照。更多信息,请参见手动创建单个快照。
自动快照依赖于自动快照策略。创建并启用自动快照策略后,阿里云会自动按照快照策略设置的时间点或周期为云盘创建快照。更多信息,请参见创建自动快照策略。
快照来源不同
在快照列表中查看手动快照和自动快照:
自动快照的快照来源为自动创建。
手动快照的快照来源为手动创建。
快照名称不同
手动快照名称在创建快照时自定义设置。
自动快照名称以auto2.0开头命名,命名格式auto2.0_yyyyMMdd_SnapshotPolicyId,其中:
auto2.0:表示自动快照,与手动快照区分。
yyyyMMdd:创建快照的日期,y表示年、M表示月、d表示天。
SnapshotPolicyId:快照对应的自动快照策略ID。
说明 在使用手动快照和自动快照过程中,会存在以下制约条件:
ESSD系列云盘(ESSD、ESSD AutoPL、ESSD Entry和ESSD同城冗余)
单块云盘支持手动和自动同时并发创建快照。但是并发创建快照有最大个数限制,详情请参见快照使用限制。如果云盘并发创建的快照个数达到了上限,则后续并发创建快照会失败。
上一代云盘(SSD云盘、高效云盘和普通云盘)
不支持手动和自动同时并发创建快照。
在自动快照创建时间点,如果云盘正在执行创建快照任务(手动或自动创建快照),则系统不会创建该时间点的自动快照,而是在下一个时间点正常创建自动快照。
如果云盘正在执行创建自动快照任务,您需要等待自动快照完成后,才能手动创建快照。
如何修改快照名称?访问ECS控制台-快照。
在快照列表中,找到目标快照,单击快照名称旁的编辑图标。
在修改名称对话框中,输入新的快照名称。
单击确定。
文件系统与普通云盘和快照有什么关系?您在磁盘分区上创建的是文件系统。文件系统负责管理磁盘空间,管理操作最终均转化为磁盘的I/O请求。磁盘会记录数据块状态,按需将数据一并拷贝到对象存储OSS,这就是创建快照的过程。文件系统与快照之间的关系如下图所示:
说明 上图中,只要被写过数据的数据块,即使在磁盘中的相关文件已经被删除,数据块仍会被记录到快照中。文件系统中所谓删除只是在需要删除的文件头部做个标记,让您知道这块空间可以利用了,不会减少磁盘本身的空间占用。
快照和镜像有什么联系和区别?镜像是用于创建和启动实例的模板,实例是基于镜像和其他配置参数创建的虚拟机,而快照用于备份实例的数据。
下图为您展示快照是实例某一时刻的数据备份,ECS 1实例和快照均可以创建自定义镜像,通过自定义镜像,您可以继续创建另一台实例。
自定义镜像和快照都可以用作数据备份,但是适用场景和功能不同,点我查看区别。
主要区别区别
镜像
快照
定义
镜像可以对整个ECS实例的配置、操作系统、已安装的软件和数据进行全量备份。更多信息,请参见通过ECS镜像备份恢复数据。
快照可以为单个云盘或云盘组(快照一致性组)上的数据创建某个时刻的完整备份。更多信息,请参见通过ECS快照备份恢复数据。
适用场景
备份短期内不会更改系统,例如已经完成发布或更新的应用系统。 将已经完成安装和配置的ECS实例制作为自定义镜像后,可用于创建新的ECS实例,例如批量部署应用。
系统及数据迁移。
跨可用区或跨地域还原系统。例如通过自定义镜像创建ECS实例时指定新的可用区;或先复制镜像到其他地域,再跨地域创建ECS实例。
定期备份云盘数据。
按照设定的周期,每日、每周或每月自动执行快照策略对云盘数据进行备份。
临时备份云盘数据。例如:
系统更新、应用发布等系统临时变更,为防止操作错误,在执行变更前手工创建快照对系统进行备份。
系统盘扩容前,创建快照备份数据。
云盘数据迁移,为云盘创建快照,将云盘作为另一块云盘的基础数据。
功能
镜像可直接用来创建ECS实例。
镜像中一定包含系统盘的数据备份。是否包含数据盘的数据备份,取决于使用的ECS实例是否存在数据盘,或者使用快照创建镜像时是否选择添加数据盘。
镜像可用于当前ECS实例及其他实例更换系统盘或创建新的ECS实例。
快照不可以直接用来创建ECS实例。
快照可以是ECS实例系统盘或数据盘的数据备份。
快照只能用于当前ECS实例云盘的数据恢复。
其他联系创建自定义镜像时:
可以通过系统盘快照创建自定义镜像。更多信息,请参见使用快照创建自定义镜像。
使用ECS实例创建自定义镜像的过程中,会为实例的每块云盘(系统盘和数据盘)创建一份快照,即创建的自定义镜像包含了ECS实例所有云盘的快照。更多信息,请参见使用实例创建自定义镜像。
删除自定义镜像和快照时:
删除自定义镜像时,可以选择删除或保留对应的快照。更多信息,请参见删除自定义镜像。
删除快照时,会检查其是否有关联镜像,如有关联镜像,需先删除镜像才能删除快照。更多信息,请参见删除快照。
重新初始化系统盘与更换系统盘(操作系统)有什么差异?主要差异如下表所示:
差异项
重新初始化系统盘
更换系统盘(操作系统)
功能差异
初始化会还原云服务器的初始化状态,初始化前后操作系统不变。
将现有的操作系统类型切换为其他类型的操作系统。
对系统盘的影响
旧系统盘不会被释放。
系统盘数据会恢复到刚创建时的状态,创建实例后安装的应用程序和产生的数据都会被清除,建议您做好数据备份。
系统盘ID、云盘类型、ECS实例的IP地址等均保持不变。
更换操作系统后,原来旧的系统盘会被释放。
会清除系统盘上的所有数据,建议您做好数据备份。
系统盘ID会变,但是云盘类型、ECS实例IP地址以及弹性网卡MAC地址保持不变。
对数据盘的影响
不会影响数据盘。
不会影响数据盘。
对快照的影响
基于系统盘创建的快照可以用于回滚云盘。
基于系统盘创建的手动快照和自动快照均会保留。
自动快照策略设置仍然有效,不需要重新设置。
旧系统盘快照不能用于回滚新系统盘,但可以用于创建自定义镜像。
基于旧盘手动创建的快照,不会被释放。
自动创建的快照,如果旧系统盘开启自动快照随云盘释放,则自动快照会被自动删除;如果未开启自动快照随云盘释放,则到期后自动释放。
旧系统盘的自动快照策略将失效,需要重新设置。
计费情况
初始化系统盘不收费。初始化前后操作系统不变,计费项不发生改变。
更换操作系统本身免费,以下情况会收取费用:
如果更换的新镜像是收费镜像,则会收取镜像费用。更多信息,请参见镜像计费。
如果更换时扩容了系统盘的云盘容量,则会收取新增容量的费用。更多信息,请参见块存储计费。
如何监控ECS快照是否创建完成?可以使用云监控订阅ECS系统事件通知,事件名称选择磁盘快照创建完成,后续可以通过事件体中的result字段判断快照是否创建完成。当result字段为accomplished表示完成 ,failed 表示失败。事件订阅及事件通知说明请参见订阅ECS系统事件通知及快照事件通知。